karmaCRM is down. We are investigating and hope to be back up and running soon.
Incident Report for karmaCRM
Resolved
This incident has been resolved.
Posted over 3 years ago. Dec 19, 2014 - 11:07 EST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted over 3 years ago. Dec 18, 2014 - 23:36 EST
Investigating
We are currently investigating this issue.
Posted over 3 years ago. Dec 18, 2014 - 16:14 EST