karmaCRM Down
Incident Report for karmaCRM
Resolved
karmaCRM is back up and running again!
Posted almost 4 years ago. Dec 18, 2014 - 10:12 EST
Investigating
We are currently investigating karma's outage.
Posted almost 4 years ago. Dec 18, 2014 - 09:22 EST