Server speed slowed.
Incident Report for karmaCRM
Resolved
This incident has been resolved.
Posted May 14, 2020 - 18:13 EDT
Investigating
We are currently investigating the problem, and will update you as soon as it is back up to the proper speed.
Posted May 14, 2020 - 16:43 EDT
This incident affected: app.karmacrm.com and api.karmacrm.com.